Pure excitement! *no pun intended*

So…I decided to pull my Pure out of the drawer and give it another go after I saw there was an update (1.3.0).

At 10:30a, I stuck my US Mobile (powered by T-Mobile) sim in and it worked. I didn’t get my hopes up because it had worked intermittently in the past for a couple of hours and then finally gave me the x of death (service never came back).

It is 7:10P and I still have service. There have been moments where texts have been delayed, but they have all gone back and forth between my Google Voice number. I was getting some errors from other texts and wondered why.

I discovered that the Pure identifies the same phone numbers differently if there is a “+1” “1” or “-” involved in the phone number!. Once I made the phone numbers 10 digits (removed all spaces, dashes, parentheses, “1”) calls and texts have been working smoothly for the most part.

I ALSO went ahead and got real bold and connected my computer to the Pure to try the tethering…I WAS ABLE TO GET NETFLIX TO STREAM VIA TETHERING ON THE PURE!!!

Now…I’m reminding myself that this could go down at any minute. But, with this progress…I am ECSTATIC and optimistic that Mudita can get this phone working. At the beginning of July I was ready to send this phone back for a refund. Patience is paying off.

I’m considering switching to T-Mobile because @Jose_Briones mentioned they have a feature called DIGITS which will allow me to receive the MMS messages that cannot be viewed on the Pure and if for some reason the Pure glitches or stops receiving SMS, I know I’ll be able to log in and see them on DIGITS until everything is running seamlessly.

What’s more is T-Mobile actually even said that my when they typed in my IMEI number, the Pure showed up and they said it is compatible with their network. They sent me screenshots and everything.



@mmallen37 Thanks for sharing this information! We are so happy that everything is working for you at the moment. Please keep us updated & let us know how it goes.

1 Like

@mmallen37 Would it be possible for you to forward those screenshots to us?


My apologies but I did not save the screenshots. I thought about it after I had closed the chat.

The phone has been showing the “x” for service quite a bit over the last two days. I kept restarting the phone whenever I saw the “x” and when the phone would turn back on it would show service bars. There was no specific amount of time the bars would last. Sometimes for hours, sometimes for 30 seconds before showing an “x”.

Last night I realized that even though the phone showed no service (“x”), I am still able to make and receive calls. I will not restart the phone and see if I continue to receive service today even though the device states that there is no service. When plugged into the Mudita Center, it states “no connection”, although right now there are 2 bars present.

When placing calls, if I select “speaker on” it will not allow me to actually switch to “speaker on” until someone connects to the call. While the phone is ringing, I have “speaker on” and it still rings as though the speaker is not on. When someone picks up, the speaker is still not on. I have to toggle to speaker off and then back on once the line is no longer ringing.


My phone always shows ‘x…’, but calls and texts work. I am on Hello Mobile (TMobile MVNO). My phone will show ‘x…’, but Mudita Center will show 2/3 bars. I have sent logs etc, so lets hope a fix will come in the future.


I have the same problem if i select speaker on. The problem had started after update Mudita OS to 1.3 version.

1 Like

@piotrek71 this is interesting. I will ask the team if this is planned to change.

1 Like

Hi guys,
I got info from out team that the speaker issue will be fixed in the next update: [MOS-667] Fix loudspeaker switching by Lefucjusz · Pull Request #4028 · mudita/MuditaOS · GitHub


Nice to hear it :grin:

1 Like

@urszula my directional pad and center button stopped working on my Pure for some reason. I tried to power down, however, I cannot toggle over the “yes” to turn the phone off. The battery seems impossible to get out. How can I reset the phone if I can’t toggle?


@mmallen37 Let’s try a battery pull- I know you said that you find it impossible to remove, but I’ll guide you through it. If that doesn’t work, I’ll ask you to report this issue to customer service as a warranty problem.
On the back side corner, you will see a slight separation in the back cover. That’s the starting point.

Stick your fingernail in there & separate the back cover from the phone. There should be a clicking noise. It’s created so the battery is easily removable & replaceable.

Then at the top of the battery, you will see another slot where your fingernail should fit to pull out the batter.

Let me know if you were able to do it.


I have the same error sometimes.


I was able to remove the battery with some the help of a card. It took a lot of pressure down and then lifting out to get the battery out.

The directional pad is back to functioning. I will see if I can upload logs. Sometimes it is hit or miss to upload the logs.


@mmallen37 I’m glad things worked out.

1 Like

Ty @mmallen37 for posting this! I am incorporating your suggestions - gtg SIM today from T-mobile. And…I agree, they were very easy to work with and also told me it should work. We shall see when it gets here :slight_smile:
Update: Works no problem (calls) - most texts so far too!

1 Like

@mrm Thanks for sharing this.

1 Like