Mudita Center on Debian

After getting an USB-C cable, I was having trouble connecting the Mudita Pure on Debian (Bullseye version) and I figured out the issue.
You need to add yourself to the “dialout” group. In my case, that looked like this:

sudo usermod -a -G dialout sandra

As usual, after adding yourself to groups, you normally need to logout and log in again. (In my case, that meant restarting xrdp since I was logged in over xrdp.)


Wow. Thank you for sharing this!


@sandra Thank you so much for being so helpful! :heart:


Yes, thank you for sharing this @sandra, finally got my Pure detected and updated, (Ubuntu 20.04).


Still having issues with Mudita Center failing to connect to either of my Pure phones, all I get is “Connecting Error Your device is not responding”.
I have group permissions to dialout, I’ve tried disconnecting/reconnecting the phone, rebooting the phone, using a different USB port, no change.
When the phone is plugged in I have the devices: /dev/ttyUSB{0-3], which are in the dialout group, and which disappear when I unplug it.
OS is Ubuntu 20.04 on x86_64. Not sure what to try next.

1 Like

@r_g Thanks for bringing this to our attention. I have forwarded your message to our devs. A few months ago you mentioned that you were able to connect & update. Did something happen in the meantime? Or is this a random occurrence.

@r_g I’ve got an update from the devs. They told me that you can can manually send the logs to our customer support mail from the ~ / Library / Application Support / @ mudita / mudita-center-app directory.
Sending Mudita Center logs to Mudita, even if the phone is not connected, can help them diagnose the problem.
Let me know when you’re able to do that.

Hello Urszula,
I don’t have a ~/Library/Application Support/@mudita/mudita-center-app directory path, but did find a ~/.config/@mudita/mudita-center-app/logs/ path I can send the log file from there. I just need the email address to send it to.
Thanks for the support.


@r_g Please send your logs to
Please let me know when you you’ve sent them, so that I can let our team know right away.

Logs have been sent. Hope that helps.

1 Like

I will let the team know. Thanks for the quick reply @r_g

@r_g Our devs suggested this:
Maybe the user needs to give permissions to one of the devices: /dev/ttyUSB{0-3].

In my case on the Linux, the below command is helpful :point_down:
sudo chmod a+rw /dev/ttyACM0

Thanks Sandra, that indeed helped ! :slight_smile: (Ubuntu 20.04)
Though with the last version of the Mudita Center , it still can’t connect, but I guess the team is working on it, I saw several other messages about that release ^^


@elie Thanks for the feedback. Yes, our team is working on it. In the meantime, can you tell me what version of MuditaOS you currently have on your phone?

My pure run currently with the 1.2.1

1 Like

Hello all,
I would like to know how to start the Mudita Center under Debian. Maybe someone of you can help me. I have downloaded the file “Mudita-Center.AppImage”. Then I tried to start it via terminal “./Mudita-Center.AppImage”.
I get the following error message:[7208:0716/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_MuditaicZ9aY/chrome-sandbox is owned by root and has mode 4755.
Trace/Breakpoint triggered

When I start the whole thing as root this message comes up:
[7867:0716/] Running as root without --no-sandbox is not supported. See 638180 - chromium - An open-source project to help move the web forward. - Monorail.
Trace/Breakpoint triggered

I would be very glad to get some help.

Many greetings


I don’t yet have a Pure but I tested the Mudita Center on Devuan and LMDE, and got this same message. I did eventually get it to work. From memory, I think I just needed to execute:

./Mudita-Center.AppImage --no-sandbox


sudo ./Mudita-Center.AppImage --no-sandbox

I can’t remember exactly which, but it was as simple as that.


Thank you, with the following command the Mudita Center starts immediately:
./Mudita-Center.AppImage --no-sandbox