Mudita Center on 1.4.1 crashing

I updated Mudia Centre to 1.4.1 today and now whenever i use it with my phone connected, it simply says “Unfortunately, synchronization failed”. “Please try to reconnect your device”. If i close the error screen, the software closes entirely. If i press Retry, i get the same error.

I’ve used numerous cables, rebooted, uninstalled / reinstalled, etc. Same result each time.
I don’t suffer this problem on previous versions of Mudita Center.

Submitted my findings to Mudita Support. Just posting here to see if others experience the same issues.
OS is Win11.


@rumpole Thanks for letting us know. I just spoke with Robert about this & he has received your support ticket & is looking into this.

I face the same issue. OS is Window 10 Pro. Mudita Pure is on v1.2.1.

2 things I want add.

  1. It is possible to circumvent the error and access the other menu items at the side panel. If you click at one of them right away after having clicked on “Try again” then the according screen is displayed and appears functional without showing the error. For instance, creating a contact in Mudita Center worked, it got added to the Mudite Pure. Also, contacts of Mudita Pure were listed. And it was possible to use the “Contact Support” function of the Help screen and sent my observation alongside the log to the Mudita Support …

  2. The Mudita Harmony having v1.6.0 can connect without any issue to the Mudita Center, the error is not shown.

This issue needs to be fixed soon. Even with the workaround I just mentioned, there is no way to upgrade the Mudita Pure or make a backup, both options are located on the Overview screen which is blocked by the error.

P.S.: Another way to avoid this error is to downgrade for now by uninstalling Mudita Center and installing the previous version, v1.3.1 if its setup is at hand …

1 Like

Looks like running Mudita Center v1.4.1 on Mac does not trigger this synchronization error, but there is other trouble about this version?!? See “… I recently updated to Mudita Center 1.4.1 and am now getting the “no contacts to import” message. …”.

On Ubuntu 20.04, exactly the same issue with the version 1.4.1 than described in the first post above.


Yes I am having the same issue with 1.4.1


Hi Guys!
Our team has been made aware of the issue & they are working on it.