The new eCommerce platform is up

I got this today when I tried to access https://store.mudita.com/sales/order/history/ :

Error 503 Backend fetch failed

Backend fetch failed

Guru Meditation:

XID: 726113


Varnish cache server

2 Likes

Interesting observation: I ordered a “Mudita Bell” from the shop. I was logged into my account during the ordering process. Nevertheless, I had to re-enter my address details. In the order confirmation, I was then addressed as “Dear Guest” and the order was not recorded under “My Orders”. Even my “Mudita Pure” order was not assigned to my account. So I’ve already bought two products from you and I’m still not a customer in your system. :pensive:

1 Like

@thilodus I’ve reported this issue to the eCommerce department. Thanks for letting me know about this. This is an unusual circumstance.

Matter is still going on about “Error 503 Backend fetch failed” when trying to access MY ORDERS.

I got feedback by Greg, Customer Support about 4 days ago: “… This issue was reported to our developers and technical team. I was informed that this is on the to-do list but unfortunately, there is no estimation as for when it will be fixed.”. Though, this is sad to note I am pleased by the responsiveness of the Customer Support. It is improving :slight_smile:

Is there someone else facing this issue too? So far, just @kirkmahoneyphd and me appears to be affected. It would be great to know as it can increase the priority of getting this fixed. Apologies if I overlooked someone else’s post. Thank you.

1 Like

@sv3np I’ve reported this to the eCommerce department. They are working on fixing this.

1 Like