Mudita Harmony - dead?

Yesterday evening my MH reached 0% charge, so I plugged it in to charge using a regular USB-C cable and an iPhone charger I use normally to charge. It didn’t charge throuout the night, so this morning I plugged it in to my Mac using USB-C cable (a different cable, which works because it works fine with my mouse) and making sure it’s a charging port. Still nothing. Also there is an hour “freezed” up on the screen along with the battery charge status which is “0%”. The screen is also not so clear, it looks like the ink is faded. MH doesn’t react to pressing any buttons. I also checked Mudita Center - not recognizing.

Images attached.

Any ideas what’s going on? Is there a “reset” button of some sort anywhere on the clock?

1 Like

@szatanica Thanks for reaching out. Make sure you use a 5V, 2amp charger. Although I am not familiar with Apple products & what chargers they use, I know it makes a difference if I charge my Mudita Harmony with one of those “Fast Chargers” vs a regular one.
Here’s the difference:

This is a Fast Charger:

1 Like

I had the exact same problem. As urszula said, the charger must be very specific. I tried using a normal Apple 5V charger but it didn’t work. Mudita was kind enough to send me their own charger free of charge and it worked with it.

You can reset the Harmony by holding down the “light” and “back” buttons for a couple of seconds, check if that works first of all.

However, my problem didn’t resolve completely after I received their charger. Since I hadn’t updated the software (still haven’t, need to do it ASAP) there was a bug in the Harmony’s software that froze the screen, and made the device unresponsive, even though the clock/software ran “correctly” in the background.
You can try to drain the battery by waiting it out for a couple of days and then plugging it in (essentially forcing it to restart). This worked for me when I used their official charger.

My recommendation is to contact Mudita and tell them about your problem if the restart button combination doesn’t work and follow their advice.


@silver Thanks for jumping in & helping out another community member.
Using the right charger is key.

1 Like